Die Mathe-Redaktion - 14.12.2017 23:56 - Registrieren/Login
Auswahl
ListenpunktHome
ListenpunktAktuell und Interessant ai
ListenpunktArtikelübersicht/-suche
ListenpunktAlle Links / Mathe-Links
ListenpunktFach- & Sachbücher
ListenpunktMitglieder / Karte
ListenpunktRegistrieren/Login
ListenpunktArbeitsgruppen
Listenpunkt5 im Schwätz / Top 15
ListenpunktWerde Mathe-Millionär!
ListenpunktFormeleditor fedgeo
Schwarzes Brett
Aktion im Forum
Suche
Stichwortsuche in Artikeln und Links von Matheplanet
Suchen im Forum
Suchtipps

Bücher
Englische Bücher
Software
Suchbegriffe:
Mathematik bei amazon
Naturwissenschaft & Technik
In Partnerschaft mit Amazon.de
Kontakt
Mail an Matroid
[Keine Übungsaufgaben!]
Impressum

Bitte beachten Sie unsere Nutzungsbedingungen, die Distanzierung, unsere Datenschutzerklärung und
die Forumregeln.

Sie können Mitglied werden oder den Newsletter bestellen.

Der Newsletter Okt. 2017

Für Mitglieder
Mathematisch für Anfänger
Wer ist Online
Aktuell sind 507 Gäste und 13 Mitglieder online.

Sie können Mitglied werden:
Klick hier.

Über Matheplanet
 
Zum letzten Themenfilter: Themenfilter:
Matroids Matheplanet Forum Index
Moderiert von Stefan_K
Matroids Matheplanet Forum Index » Textsatz mit LaTeX » Konflikt zwischen TeXmaker und Windows 10?
Druckversion
Druckversion
Antworten
Antworten
Autor
Universität/Hochschule Konflikt zwischen TeXmaker und Windows 10?
Garfield17
Aktiv Letzter Besuch: im letzten Monat
Dabei seit: 26.02.2014
Mitteilungen: 35
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Themenstart: 2017-04-20


Hallo zusammen,

ich bin heute auf ein merkwürdiges Phänomen gestoßen. Kurz zur Vorgeschichte: Ich habe damals meine BA in Latex geschrieben. War auch alles super und hat bestens funktioniert. Damals habe ich die TeX-Files einfach auf meinem USB-Stick gelassen, und dann via TeXmaker, über meinen PC- geöffnet, und konnte so das Dokument auch auf meinem Laptop kompilieren (dort waren natürlich MikTeX und TeXmaker instaliert).

Jetzt wollte ich das Layout meiner BA für ein anderes Dokument wieder benutzen und da dachte ich, ich  gehe genauso vor, d.h ich lasse die TeX-Files einfach auf dem USB-Stick, und benutze je nach dem, entweder meinen PC oder Laptop (beide haben gleiche Versionen).

Jetzt war ich nur überrascht, als ich das Dokument kompilieren wollte. Sobald ich Labels einfüge und danach entferne scheint TeXmaker nicht mehr richtig zu kompilieren. Das Label und die Referenz gehen zwar weg, dafür kommen anstatt dessen andere Zeichenketten, die ich zwar im Editor löschen kann, aber nach dem Kompilieren und erneutem Öffnen sind diese Zeichenketten wieder im TeX-File. Das Phänomen tritt auch bei einem anderen Editor auf...

Jedoch scheint bei normalen Texteingaben alles glatt zu gehen.

Ich benutze mehrere zusammengesette Dokumente und nutze das TeXmaker Tool mit der Masterdatei.

Da dieser Fehler beim Kompilieren auf der Festplatte meines PCs nicht auftritt vermute ich stark, dass es mit dem USB-Stick zusammenhängen muss. Habe dieses Phänomen bei zwei verschiedenen USB-Sticks beobachtet.

Habt ihr eine Idee woran das liegen könnte? Vieleicht ein Problem mit Windows 10 oder dem Cleverref oder hyperref Paket?

Wäre für jede Idee oder Diskussionsbeitrag dankbar, weil ich das eigentlich sehr praktisch fand, die TeX-Dateien auf dem Stick zu lassen.

Vielleicht wird es anhand eines Beispiels klarer:
1. Das Minimalbeispiel auf einen USB-Stick speichern.
2. Im Tex-Maker das Dokument öfnnen und zweimal kompilieren bis der Link passt.
3. sowohl \label{1} als auch \Cref{1} entfernen und wieder zweimal kompilieren. Das Dokument schließen.
4. Dann das Dokument wieder über TeXmaker öffnen
5. Und jetzt das Komische: Dann erscheint bei mir etwas Merkwürdiges (siehe zweiter Quellcode).
Latex
\documentclass[12pt,a4paper,titlepage,twoside]{article}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{makeidx}
\usepackage{graphicx}
\usepackage{lmodern}
\usepackage[left=2.75cm,right=2.75cm,top=3.85cm,bottom=3.85cm]{geometry}
\allowdisplaybreaks
\usepackage{dsfont}
\usepackage{mathrsfs}
\usepackage{hyperref}
\usepackage{color}
\usepackage{amsthm}
\usepackage{blindtext}
\usepackage{fancyhdr}
\usepackage{verbatim}
\usepackage{enumitem} 
\usepackage{url}
\usepackage{mathtools}
\usepackage[nameinlink,german]{cleveref}
\usepackage{float}
\usepackage{subfigure}
\usepackage{romannum}
\usepackage{capt-of}
 
\begin{document}
\blindtext\\
\section{Hallo Welt} 
\subsection{Hallo1}\label{1}
\subsection{Hallo2}
hallo. Jetzt schreibe ich weiter \Cref{1}. Hallo zusammen.
 
\end{document}

Code, der nach Punkt 5. in meinem TeX-File steht:
Latex
\documentclass[12pt,a4paper,titlepage,twoside]{article}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{makeidx}
\usepackage{graphicx}
\usepackage{lmodern}
\usepackage[left=2.75cm,right=2.75cm,top=3.85cm,bottom=3.85cm]{geometry}
\allowdisplaybreaks
\usepackage{dsfont}
\usepackage{mathrsfs}
\usepackage{hyperref}
\usepackage{color}
\usepackage{amsthm}
\usepackage{blindtext}
\usepackage{fancyhdr}
\usepackage{verbatim}
\usepackage{enumitem} 
\usepackage{url}
\usepackage{mathtools}
\usepackage[nameinlink,german]{cleveref}
\usepackage{float}
\usepackage{subfigure}
\usepackage{romannum}
\usepackage{capt-of}
 
\begin{document}
\blindtext\\
\section{Hallo Welt} 
\subsection{Hallo1}\label{1}
\subsection{Hallo2}
hallo. Jetzt schreibe ich weiter \Cref{1}. Hallo zusammen.
 
\end{document}
 
 
 
 
llo. Jetzt schreibe ich weiter. Hallo zusammen.
 
\end{document}
 
 
 
\end{document}
 
 
ich weiter. Hallo zusammen 
 
\end{document}
 

Kommt das bei euch auch?? confused  confused  confused



  Profil  Quote  Link auf diesen Beitrag Link
Wally
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 02.11.2004
Mitteilungen: 7936
Aus: Dortmund, Old Europe
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.1, eingetragen 2017-04-21


Hallo,

das sieht eher wie ein Hardwarefehler des USB-Anschlusses aus.

Wally



  Profil  Quote  Link auf diesen Beitrag Link
Garfield17
Aktiv Letzter Besuch: im letzten Monat
Dabei seit: 26.02.2014
Mitteilungen: 35
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.2, vom Themenstarter, eingetragen 2017-04-21


Okay, dann sollte ich es mal an der anderen USB Buchse probieren.

Was könnte man gegen so einen Hardware Fehler machen?



  Profil  Quote  Link auf diesen Beitrag Link
viertel
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 04.03.2003
Mitteilungen: 26063
Aus: Hessen
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.3, eingetragen 2017-04-21


Garfield17 schreibt:
Was könnte man gegen so einen Hardware Fehler machen?
Klingt banal/blöd, aber wenn dem wirklich so ist: nicht benutzen.
Das Gerät deswegen auszumustern wäre wohl übertrieben.


-----------------
Bild



  Profil  Quote  Link auf diesen Beitrag Link
Garfield17
Aktiv Letzter Besuch: im letzten Monat
Dabei seit: 26.02.2014
Mitteilungen: 35
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.4, vom Themenstarter, eingetragen 2017-04-21


Okay...

Was mich nur stuzig macht ist, dass die Probleme ja nur bei Veränderungen von Labels oder Referenzen aufgetreten sind. Bei normaler Textarbeit nicht...

Auf jeden Fall sollte ja kein Latex Vorgang Veränderungen am TeX Dokument vornehmen, oder?





  Profil  Quote  Link auf diesen Beitrag Link
Wally
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 02.11.2004
Mitteilungen: 7936
Aus: Dortmund, Old Europe
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.5, eingetragen 2017-04-21


Du kannst ja mal die Latex-Datei schreibgeschützt machen und sehen was passiert.

Wally



  Profil  Quote  Link auf diesen Beitrag Link
Garfield17
Aktiv Letzter Besuch: im letzten Monat
Dabei seit: 26.02.2014
Mitteilungen: 35
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.6, vom Themenstarter, eingetragen 2017-04-21


Also habe jetzt mal die andere USB-Buchse benutzt und auch bei meinem Laptop ausprobiert. Bei allen tritt der Fehler auf. Daher möchte ich eigentlich einen Hardwarefehler an allen USB Schnittstellen ausschließen.

Vermutlich liegt es an einem Windows-Update oder so, welches den Zugriff auf den USB-Stick anders regelt  confused

Dann bleibt mir wohl nichts anderes übrig, als die Dateien auf meiner Festplatte zu lassen  frown

Wenn ich Datei schreibgeschützt maache kann ich erst gar nicht kompilieren...



  Profil  Quote  Link auf diesen Beitrag Link
Chandler
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 07.03.2011
Mitteilungen: 896
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.7, eingetragen 2017-04-21


Hast du mal einen anderen USB-Stick ausprobiert?


-----------------
"vegan sausage in our bowels"
Hier ein super Hörbuch.



  Profil  Quote  Link auf diesen Beitrag Link
Garfield17
Aktiv Letzter Besuch: im letzten Monat
Dabei seit: 26.02.2014
Mitteilungen: 35
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.8, vom Themenstarter, eingetragen 2017-04-21


Ja hab ich auch schon probiert und leider das gleiche Problem.

Hat es mal von Euch jemand ausprobiert? Tritt bei euch das Problem nicht auf?



  Profil  Quote  Link auf diesen Beitrag Link
Wally
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 02.11.2004
Mitteilungen: 7936
Aus: Dortmund, Old Europe
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.9, eingetragen 2017-04-21


Hallo,

bei mir wird auch eine schreibgeschützte TeX-Datei akzeptiert.

Daher ist das ein sehr sehr seltsamer Fehler.

Wally

[Die Antwort wurde nach Beitrag No.7 begonnen.]



  Profil  Quote  Link auf diesen Beitrag Link
Garfield17
Aktiv Letzter Besuch: im letzten Monat
Dabei seit: 26.02.2014
Mitteilungen: 35
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.10, vom Themenstarter, eingetragen 2017-04-21


Okay. Ich habe die TeX-Datei als schreibgeschützt deklariert und dann kam die Meldung, dass die Datei nicht gespeichert werden könne. Ich solle meine Schreibberechtigung überprüfen.



  Profil  Quote  Link auf diesen Beitrag Link
Wally
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 02.11.2004
Mitteilungen: 7936
Aus: Dortmund, Old Europe
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.11, eingetragen 2017-04-23


Das deutet auf einen Fehler in Texmaker hin (das benutze ich selbst nicht).
Vielleicht solltest du die Autoren oder eine Supportgruppe latex.org/forum/ oder tex.stackexchange.com/ oder golatex.de/ oder texblog.net/ oder....) kontaktieren.

Wally



  Profil  Quote  Link auf diesen Beitrag Link
Garfield17
Aktiv Letzter Besuch: im letzten Monat
Dabei seit: 26.02.2014
Mitteilungen: 35
Aus:
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.12, vom Themenstarter, eingetragen 2017-05-02


Okay danke für den Hinweis.

Ich könnte mal den TeXmaker neuinstallieren. Das wollte ich eigentlich vermeiden, weil ich einige wichtige aufwendigere Konfigurationen vorgenommen habe, von denen ich mir nicht mehr sicher bin wie ich sie damals hinbekommen habe.

Werde mich am Wochenende nochmals dahinterklemmen.

Vielen Dank für Eure Antworten. Sie haben mir sehr geholfen.



  Profil  Quote  Link auf diesen Beitrag Link
Garfield17 hat die Antworten auf ihre/seine Frage gesehen.
Garfield17 wird per Mail über neue Antworten informiert.
Neues Thema [Neues Thema] Antworten [Antworten]    Druckversion [Druckversion]

 


Wechsel in ein anderes Forum:
 Suchen    
 
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © 2001-2017 by Matroids Matheplanet
This web site was made with PHP-Nuke, a web portal system written in PHP. PHP-Nuke is Free Software released under the GNU/GPL license.
Ich distanziere mich von rechtswidrigen oder anstößigen Inhalten, die sich trotz aufmerksamer Prüfung hinter hier verwendeten Links verbergen mögen.
Lesen Sie die Nutzungsbedingungen, die Distanzierung, die Datenschutzerklärung und das Impressum.
[Seitenanfang]