Matroids Matheplanet Forum Index
Moderiert von Stefan_K
Matroids Matheplanet Forum Index » Textsatz mit LaTeX » LaTeX-Befehl für Angström
Druckversion
Druckversion
Antworten
Antworten
Autor
Universität/Hochschule LaTeX-Befehl für Angström
peterpacult
Aktiv Letzter Besuch: im letzten Quartal
Dabei seit: 04.05.2020
Mitteilungen: 34
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Themenstart: 2020-11-30


Hallo,

wie kann ich die mathematische Einheit Angström mit LaTeX darstellen? Gibt es dafür einen besonderen Befehl?

Vielen Dank und viele Grüße!

Peter



Wahlurne Für peterpacult bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
zippy
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.10.2018
Mitteilungen: 1777
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.1, eingetragen 2020-11-30


2020-11-30 09:39 - peterpacult im Themenstart schreibt:
wie kann ich die mathematische Einheit Angström mit LaTeX darstellen?

Gibt es einen Grund, warum du nicht einfach "latex angstrom" in Google eintippst, wo du \AA $=$ <math>\hbox{\AA}</math> finden würdest?

(In MathML funktioniert der Ring-Akzent \r, auf dem \AA basiert, übrigens nicht.)

--zippy



Wahlurne Für zippy bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Wally
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 02.11.2004
Mitteilungen: 9034
Herkunft: Dortmund, Old Europe
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.2, eingetragen 2020-11-30


Hallo peterpacult,

das kannst du wahrscheinlich direkt eingeben (falls du die utf-8-Codierung verwendest, die in aktuellem Latex voreingestellt ist).

Sonst könnte \AA gehen mit \usepackage{amssymb}.

Viele Grüße

Wally

[Die Antwort wurde vor Beitrag No.1 begonnen.]



Wahlurne Für Wally bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
zippy
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.10.2018
Mitteilungen: 1777
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.3, eingetragen 2020-11-30


2020-11-30 10:23 - Wally in Beitrag No. 2 schreibt:
Sonst könnte \AA gehen mit \usepackage{amssymb}.

\AA ist ein Standard-LaTeX-Befehl, man benötigt also kein amssymb.



Wahlurne Für zippy bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
peterpacult
Aktiv Letzter Besuch: im letzten Quartal
Dabei seit: 04.05.2020
Mitteilungen: 34
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.4, vom Themenstarter, eingetragen 2020-11-30


\usepackage{amssymb} ist als Paket sogar in der Präambel, aber ich verwende nicht "utf8", sondern "ansinew" und da wird mir bei \AA zwar keine Fehlermeldung vom Compiler angezeigt, aber in der pdf erscheint auch kein Symbol...
Was kann ich tun, damit das Symbol angezeigt wird? Ich habe mir bislang mit einer \stackrel-Konstruktion beholfen.

Viele Grüße

Peter



Wahlurne Für peterpacult bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
markusv
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.01.2017
Mitteilungen: 307
Herkunft: Leipzig
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.5, eingetragen 2020-11-30


Für Größen/Einheiten-Paare stellt das Paket siunitx umfangreiche Hilfe zur Verfügung. Mit dem Befehl \SI{<Größe>}{<Einheit>} lassen sich sowohl im Text- und Mathematikmodus "DIN-konforme" (aufrechte Schreibweise der Einheiten, korrekter Abstand etc.) setzen.

Für Angström gibt es den Befehl \angstrom:
LaTeX
\documentclass{article}
\usepackage[locale=DE]{siunitx}
 
\begin{document}
\si{\angstrom} %nur die Einheit
\SI{3}{\angstrom} %Größen/Einheiten-Paar
\end{document}

Da utf8 mittlerweile im LaTeX-Kern verankert ist, sollte man ansinew nicht mehr verwenden.


-----------------
Hilfe bei der Erstellung von Vorlagen, wissenschaftlichen Arbeiten, Bewerbungen etc. in LaTeX unter help-latex(at)web.de



Wahlurne Für markusv bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Wario
Aktiv Letzter Besuch: in der letzten Woche
Dabei seit: 01.05.2020
Mitteilungen: 295
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.6, eingetragen 2020-11-30


In MathML kann das Unicodezeichen verwendet werden:
$r = 2Å$



Wahlurne Für Wario bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
peterpacult
Aktiv Letzter Besuch: im letzten Quartal
Dabei seit: 04.05.2020
Mitteilungen: 34
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.7, vom Themenstarter, eingetragen 2020-12-01


2020-11-30 12:38 - markusv in Beitrag No. 5 schreibt:
Für Größen/Einheiten-Paare stellt das Paket siunitx umfangreiche Hilfe zur Verfügung. Mit dem Befehl \SI{<Größe>}{<Einheit>} lassen sich sowohl im Text- und Mathematikmodus "DIN-konforme" (aufrechte Schreibweise der Einheiten, korrekter Abstand etc.) setzen.

Für Angström gibt es den Befehl \angstrom:
LaTeX
\documentclass{article}
\usepackage[locale=DE]{siunitx}
 
\begin{document}
\si{\angstrom} %nur die Einheit
\SI{3}{\angstrom} %Größen/Einheiten-Paar
\end{document}

Da utf8 mittlerweile im LaTeX-Kern verankert ist, sollte man ansinew nicht mehr verwenden.

Hallo markusv,

mit dem siunitx-Paket funktioniert es bei mir leider auch nicht...
Liegt das dann vielleicht an ansinew? Bei utf8 hatte ich aber leider wiederum das Problem, dass mir z.B. Umlaute nicht angezeigt werden, bzw. die "betroffenen" Buchstaben einfach weggelassen werden, sodass die Wörter nicht mehr lesbar sind. Hast du da einen Tipp für mich, wie man das vielleicht beheben kann? Das steht mir momentan bezüglich eines Umstieges auf utf8 im Weg...

Viele Grüße

Peter



Wahlurne Für peterpacult bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
DerEinfaeltige
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 11.02.2015
Mitteilungen: 2612
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.8, eingetragen 2020-12-01


Wenn du die Eingabe mit utf-8 kodierst, sollte es keine Probleme geben.

Vermutung:
Dein Texteditor und/oder dein Dokument nutzen eine andere Zeichenkodierung als utf-8.
Das führt dann zu Problemen, da der Compiler bei \usepackage[utf8]{inputenc} ein in utf-8 kodiertes Dokument erwartet und andere Zeichenkodierungen wie ISO-8859-latin1 nicht versteht.


-----------------
Why waste time learning when ignorance is instantaneous?
- Bill Watterson -



Wahlurne Für DerEinfaeltige bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
zippy
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.10.2018
Mitteilungen: 1777
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.9, eingetragen 2020-12-01


2020-11-30 11:55 - peterpacult in Beitrag No. 4 schreibt:
\usepackage{amssymb} ist als Paket sogar in der Präambel, aber ich verwende nicht "utf8", sondern "ansinew" und da wird mir bei \AA zwar keine Fehlermeldung vom Compiler angezeigt, aber in der pdf erscheint auch kein Symbol...

Dann ist irgendetwas faul an deiner $\TeX$-Installation. Bei mit erzeugt pdflatex (TeX Live 2020, Version pdfTeX 3.14159265-2.6-1.40.21) aus \AA mit und ohne \usepackage{amssymb} ein Å.

[Die Antwort wurde nach Beitrag No.7 begonnen.]



Wahlurne Für zippy bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
peterpacult
Aktiv Letzter Besuch: im letzten Quartal
Dabei seit: 04.05.2020
Mitteilungen: 34
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.10, vom Themenstarter, eingetragen 2020-12-03


Hallo zippy,

könnte es eine Rolle spielen, dass ich mit MiKTeX arbeite? Allerdings sollten doch die Pakete bei MiKTeX und TeX Live die gleichen sein, oder?



Wahlurne Für peterpacult bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
markusv
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.01.2017
Mitteilungen: 307
Herkunft: Leipzig
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.11, eingetragen 2020-12-03


Ich bin zwar nicht zippy, aber ich antworte trotzdem mal darauf :)

MikTeX und TeXLive greifen selbstverständlich auf die gleichen Pakete (inhaltlich) zurück. Entscheidend ist, wie aktuell dein System allgemein ist. Tippe in der Kommandozeile doch mal "pdflatex --version" ein und zeige uns die Ausgabe.  


-----------------
Hilfe bei der Erstellung von Vorlagen, wissenschaftlichen Arbeiten, Bewerbungen etc. in LaTeX unter help-latex(at)web.de



Wahlurne Für markusv bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
zippy
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.10.2018
Mitteilungen: 1777
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.12, eingetragen 2020-12-03


2020-12-03 09:14 - peterpacult in Beitrag No. 10 schreibt:
Allerdings sollten doch die Pakete bei MiKTeX und TeX Live die gleichen sein, oder?

\AA benötigt kein zusätzliches Paket, das wird schon in LaTeX selbst definiert:
This is pdfTeX, Version 3.14159265-2.6-1.40.21 (TeX Live 2020 Gentoo Linux) (preloaded format=latex)
 restricted \write18 enabled.
**\show\AA
entering extended mode
LaTeX2e <2020-02-02> patch level 5
L3 programming layer <2020-02-25>
> \AA=macro:
->\r A.

Wenn du trotzdem nichts siehst, fehlt also kein Paket, sondern in deiner Installation ist irgendetwas faul.

[Die Antwort wurde nach Beitrag No.10 begonnen.]



Wahlurne Für zippy bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
markusv
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.01.2017
Mitteilungen: 307
Herkunft: Leipzig
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.13, eingetragen 2020-12-03


2020-12-01 09:20 - peterpacult in Beitrag No. 7 schreibt:
2020-11-30 12:38 - markusv in Beitrag No. 5 schreibt:
Für Größen/Einheiten-Paare stellt das Paket siunitx umfangreiche Hilfe zur Verfügung. Mit dem Befehl \SI{<Größe>}{<Einheit>} lassen sich sowohl im Text- und Mathematikmodus "DIN-konforme" (aufrechte Schreibweise der Einheiten, korrekter Abstand etc.) setzen.

Für Angström gibt es den Befehl \angstrom:
LaTeX
\documentclass{article}
\usepackage[locale=DE]{siunitx}
 
\begin{document}
\si{\angstrom} %nur die Einheit
\SI{3}{\angstrom} %Größen/Einheiten-Paar
\end{document}

Da utf8 mittlerweile im LaTeX-Kern verankert ist, sollte man ansinew nicht mehr verwenden.

Hallo markusv,

mit dem siunitx-Paket funktioniert es bei mir leider auch nicht...
Liegt das dann vielleicht an ansinew? Bei utf8 hatte ich aber leider wiederum das Problem, dass mir z.B. Umlaute nicht angezeigt werden, bzw. die "betroffenen" Buchstaben einfach weggelassen werden, sodass die Wörter nicht mehr lesbar sind. Hast du da einen Tipp für mich, wie man das vielleicht beheben kann? Das steht mir momentan bezüglich eines Umstieges auf utf8 im Weg...

Viele Grüße

Peter
Tut mir leid, das habe ich gerade erst gesehen. UTF8 kann alle deutschen Sonderzeichen lesen und verstehen. Wie gesagt, ist eine Angabe von \usepackage[utf8]{inputenc} nicht mehr notwendig, da LaTeX sowieso utf8 erwartet. Evtl. musst du deine .tex-Datei als utf8-kodiert abspeichern. LaTeX-Editoren machen das normalerweise selbstständig. Welchen nutzt du? Ggf. würde ich die .tex-Datei mit einem einfachen Editor (Windows Editor) öffnen und nochmal neu speichern und dort die Kodierung anpassen.


-----------------
Hilfe bei der Erstellung von Vorlagen, wissenschaftlichen Arbeiten, Bewerbungen etc. in LaTeX unter help-latex(at)web.de



Wahlurne Für markusv bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
peterpacult
Aktiv Letzter Besuch: im letzten Quartal
Dabei seit: 04.05.2020
Mitteilungen: 34
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.14, vom Themenstarter, eingetragen 2020-12-03


Hallo markusv,

hier die Daten zu meinem MiKTeX-System:

MiKTeX-pdfTeX 2.9.7029 (1.40.20) (MiKTeX 2.9.7050 64-bit)
Copyright (C) 1982 D. E. Knuth, (C) 1996-2018 Han The Thanh
TeX is a trademark of the American Mathematical Society.
using bzip2 version 1.0.6, 6-Sept-2010
compiled with curl version 7.61.1; using libcurl/7.61.1 WinSSL
compiled with expat version 2.2.6; using expat_2.2.6
compiled with jpeg version 9.3
compiled with liblzma version 50020042; using 50020042
compiled with libpng version 1.6.35; using 1.6.35
compiled with libressl version LibreSSL 2.8.2; using LibreSSL 2.8.2
compiled with MiKTeX Application Framework version 4.6961; using 4.6961
compiled with MiKTeX Core version 14.7079; using 14.7079
compiled with MiKTeX Archive Extractor version 1.6882; using 1.6882
compiled with MiKTeX Package Manager version 6.7072; using 6.7072
compiled with poppler version 0.60.1
compiled with uriparser version 0.9.2
compiled with zlib version 1.2.11; using 1.2.11

Ich glaube, der Hinweis mit der Speicherung als utf-8 hat geholfen; ich arbeite mit dem TeXniccenter (Version 2.02) und dort war als Codierung ANSI eingestellt. Jetzt scheint alles zu laufen.

Heißt das jetzt, dass ich die Zeile \usepackage[utf8]{inputenc} ersatzlos aus meiner Präambel streichen kann?



Wahlurne Für peterpacult bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
markusv
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 24.01.2017
Mitteilungen: 307
Herkunft: Leipzig
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.15, eingetragen 2020-12-03


2020-12-03 09:47 - peterpacult in Beitrag No. 14 schreibt:
Ich glaube, der Hinweis mit der Speicherung als utf-8 hat geholfen; ich arbeite mit dem TeXniccenter (Version 2.02) und dort war als Codierung ANSI eingestellt. Jetzt scheint alles zu laufen.
Sehr schön! Du erhälst jetzt also auch das Angström-Symbol? TeXnicCenter wird nicht mehr aktualisiert, daher vielleicht auch der Umstand, dass utf8 nicht voreingestellt ist bzw. automatisch umkodiert wurde.

2020-12-03 09:47 - peterpacult in Beitrag No. 14 schreibt:
Heißt das jetzt, dass ich die Zeile \usepackage[utf8]{inputenc} ersatzlos aus meiner Präambel streichen kann?
Ja.


-----------------
Hilfe bei der Erstellung von Vorlagen, wissenschaftlichen Arbeiten, Bewerbungen etc. in LaTeX unter help-latex(at)web.de



Wahlurne Für markusv bei den Matheplanet-Awards stimmen
Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
peterpacult hat die Antworten auf ihre/seine Frage gesehen.
Neues Thema [Neues Thema] Antworten [Antworten]    Druckversion [Druckversion]

 


Wechsel in ein anderes Forum:
 Suchen    
 
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © 2001-2021 by Matroids Matheplanet
This web site was originally made with PHP-Nuke, a former web portal system written in PHP that seems no longer to be maintained nor supported. PHP-Nuke is Free Software released under the GNU/GPL license.
Ich distanziere mich von rechtswidrigen oder anstößigen Inhalten, die sich trotz aufmerksamer Prüfung hinter hier verwendeten Links verbergen mögen.
Lesen Sie die Nutzungsbedingungen, die Distanzierung, die Datenschutzerklärung und das Impressum.
[Seitenanfang]