Matroids Matheplanet Forum Index
Moderiert von matroid Gockel
Matheplanet » Bug- und Request-Tracker » Benutzerdefinierte LaTeX-Befehle werden in der Themenübersicht nicht richtig angezeigt
Autor
Universität/Hochschule J Benutzerdefinierte LaTeX-Befehle werden in der Themenübersicht nicht richtig angezeigt
Nuramon
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 23.01.2008
Mitteilungen: 3018
  Themenstart: 2021-07-10

Hallo Matroid, sowohl Wario als auch ich haben LaTeX-Makros \floor und \ceil in unseren Latex-Profilen. Im normalen Thread werden die auch richtig kompiliert, aber beim Verfassen einer Antwort sehe ich in der Themenübersicht folgendes: https://matheplanet.com/matheplanet/nuke/html/uploads/b/21445_Screenshot_2021-07-10_110041.png Mein eigenes Latex-Profil wird also berücksichtigt, das von Wario aber nicht. Link zum Thread hier.


   Profil
Wario
Aktiv Letzter Besuch: in der letzten Woche
Dabei seit: 01.05.2020
Mitteilungen: 634
  Beitrag No.1, eingetragen 2021-07-10

\quoteon(2021-07-10 11:07 - Nuramon im Themenstart) Hallo Matroid, sowohl Wario als auch ich haben LaTeX-Makros \floor und \ceil in unseren Latex-Profilen. Im normalen Thread werden die auch richtig kompiliert, aber beim Verfassen einer Antwort sehe ich in der Themenübersicht folgendes: https://matheplanet.com/matheplanet/nuke/html/uploads/b/21445_Screenshot_2021-07-10_110041.png Mein eigenes Latex-Profil wird also berücksichtigt, das von Wario aber nicht. Link zum Thread hier. \quoteoff Bei mir passt alles, ich überprüfe auch alles. Eigentlich sollte es einmal reichen, aber bevor man da groß rumexperimentiert, am besten die Befehle \sourceon (latex) \newcommand\ceil[1]{\left\lceil #1 \right\rceil} \newcommand\floor[1]{\left\lfloor #1 \right\rfloor} \sourceoff immer in jeden Beitrag übernehmen.


   Profil
Nuramon
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 23.01.2008
Mitteilungen: 3018
  Beitrag No.2, vom Themenstarter, eingetragen 2021-07-10

\quoteon(2021-07-10 12:42 - Wario in Beitrag No. 1) Bei mir passt alles, ich überprüfe auch alles. \quoteoff Auch wenn du auf "Post Reply" klickst und dann runterscrollst?


   Profil
Nuramon
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 23.01.2008
Mitteilungen: 3018
  Beitrag No.3, vom Themenstarter, eingetragen 2021-07-10

\(\begingroup\)\(\renewcommand{\Re}{\operatorname{Re}} \renewcommand{\Im}{\operatorname{Im}} \newcommand{\End}{\operatorname{End}} \newcommand{\id}{\operatorname{id}} \newcommand{\GL}{\operatorname{GL}} \newcommand{\im}{\operatorname{im}} \newcommand{\sgn}{\operatorname{sgn}} \newcommand{\d}{{\rm d}} \newcommand{\rg}{\operatorname{rg}} \newcommand{\spur}{\operatorname{spur}} \newcommand{\Hom}{\operatorname{Hom}} \newcommand{\tr}{\operatorname{tr}} \newcommand{\opn}{\operatorname} \newcommand\ceil[1]{\left\lceil #1 \right\rceil} \newcommand\floor[1]{\left\lfloor #1 \right\rfloor}\) Ach so, ich sehe gerade, dass du das gar nicht in deinem Latex-Profil hast. Dann liegt es also daran, dass du \ceil und \floor im Themenstart definiert hast und das in der Themenübersicht nicht übernommen wird. Möglicherweise ist das Problem, dass die Themenübersicht die neuesten Beiträge zuerst anzeigt, und daher der Beitrag mit der Definition ganz unten steht. $\test$\(\endgroup\)


   Profil
Nuramon
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 23.01.2008
Mitteilungen: 3018
  Beitrag No.4, vom Themenstarter, eingetragen 2021-07-10

\(\begingroup\)\(\renewcommand{\Re}{\operatorname{Re}} \renewcommand{\Im}{\operatorname{Im}} \newcommand{\End}{\operatorname{End}} \newcommand{\id}{\operatorname{id}} \newcommand{\GL}{\operatorname{GL}} \newcommand{\im}{\operatorname{im}} \newcommand{\sgn}{\operatorname{sgn}} \newcommand{\d}{{\rm d}} \newcommand{\rg}{\operatorname{rg}} \newcommand{\spur}{\operatorname{spur}} \newcommand{\Hom}{\operatorname{Hom}} \newcommand{\tr}{\operatorname{tr}} \newcommand{\opn}{\operatorname} \newcommand\ceil[1]{\left\lceil #1 \right\rceil} \newcommand\floor[1]{\left\lfloor #1 \right\rfloor}\) $\newcommand{test}{Erfolg}$ $\test$\(\endgroup\)


   Profil
Nuramon
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 23.01.2008
Mitteilungen: 3018
  Beitrag No.5, vom Themenstarter, eingetragen 2021-07-10

Ok es liegt wohl doch nicht an der umgekehrten Reihenfolge, sonst könnte man in der Themenübersicht in No.3 "Erfolg" lesen statt "\test".


   Profil
Wario
Aktiv Letzter Besuch: in der letzten Woche
Dabei seit: 01.05.2020
Mitteilungen: 634
  Beitrag No.6, eingetragen 2021-07-10

\quoteon(2021-07-10 12:55 - Nuramon in Beitrag No. 3) Ach so, ich sehe gerade, dass du das gar nicht in deinem Latex-Profil hast. \quoteoff Da kommt möglichst überhaupt nichts rein, das schafft nur Verwirrung beim Helfer. In der Vorschau sind auch Fehler, beim Absenden ist es gut. Es ist trotzdem komisch, weil Befehle, die im Themenstart definiert wurden, m.W. im ganzen Beitrag verwendbar sein sollten. So war es m.M.n. auch mal. Egal, ich kopiere das einfach ein jeden Beitrag. [Die Antwort wurde nach Beitrag No.3 begonnen.]


   Profil
matroid
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 12.03.2001
Mitteilungen: 14386
Wohnort: Solingen
  Beitrag No.7, eingetragen 2021-07-10

Hallo Nuramon, ich habe es mir jetzt angesehen. Wario verwendet keine Latex-Profil. Demnach muss er, die von ihm benötigten Befehle auch in jedem Beitrag neu definieren. Wario schreibt in #6 noch: "Es ist trotzdem komisch, weil Befehle, die im Themenstart definiert wurden, m.W. im ganzen Beitrag verwendbar sein sollten. So war es m.M.n. auch mal." Nein, das war nie so. Ansonsten wäre es eine Fehlerquelle. Haben nämlich zwei Mitglieder einen gleichnamigen Befehl unterschiedlich definiert, dann soll es nicht von der Reihenfolge abhängen, welche Definition gewinnt. Darum gelten Latex-Befehle nur für den jeweiligen Beitrag. Wenn du aber bestimmte Befehle hast, die du häufig verwendest, und du möchtest sie nicht immer wieder neu in deine Beiträge hineinkopieren, dann kannst du diese im persönlichen Latex-Profil hinterlegen. Die dort von dir werden dann für alle deine Beiträge automatisch mit geladen. Gruß Matroid


   Profil
Nuramon
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 23.01.2008
Mitteilungen: 3018
  Beitrag No.8, vom Themenstarter, eingetragen 2021-07-12

\(\begingroup\)\(\renewcommand{\Re}{\operatorname{Re}} \renewcommand{\Im}{\operatorname{Im}} \newcommand{\End}{\operatorname{End}} \newcommand{\id}{\operatorname{id}} \newcommand{\GL}{\operatorname{GL}} \newcommand{\im}{\operatorname{im}} \newcommand{\sgn}{\operatorname{sgn}} \newcommand{\d}{{\rm d}} \newcommand{\rg}{\operatorname{rg}} \newcommand{\spur}{\operatorname{spur}} \newcommand{\Hom}{\operatorname{Hom}} \newcommand{\tr}{\operatorname{tr}} \newcommand{\opn}{\operatorname} \newcommand\ceil[1]{\left\lceil #1 \right\rceil} \newcommand\floor[1]{\left\lfloor #1 \right\rfloor}\) Hallo Matroid, danke für die Antwort. \quoteon Wario schreibt in #6 noch: "Es ist trotzdem komisch, weil Befehle, die im Themenstart definiert wurden, m.W. im ganzen Beitrag verwendbar sein sollten. So war es m.M.n. auch mal." Nein, das war nie so. Ansonsten wäre es eine Fehlerquelle. Haben nämlich zwei Mitglieder einen gleichnamigen Befehl unterschiedlich definiert, dann soll es nicht von der Reihenfolge abhängen, welche Definition gewinnt. Darum gelten Latex-Befehle nur für den jeweiligen Beitrag. \quoteoff hast Du hieran vor kurzem etwas geändert? Ich hatte das nämlich auch so in Erinnerung wie Wario: Wenn ich in der Vergangenheit einen Befehl in Beitrag $n$ definiert hatte, dann konnte ich den auch noch in Beitrag $n+1,n+2,\ldots$ benutzen ohne ihn neu definieren zu müssen. Jetzt ist das jedenfalls nicht mehr so: $\test$ (\test habe ich in No.4 definiert und funktioniert jetzt nicht mehr (soll es Deiner Antwort gemäß aber auch gar nicht)). Wenn das schon immer so war, dann kann ich mir aber nicht erklären, warum in der normalen Threadansicht die \ceil und \floor Befehle von Wario kompiliert wurden, aber in der Themenübersicht, die man sieht, wenn man auf "Post Reply" drückt, nicht. [Mittlerweile hat Wario seine Beiträge alle editiert und die Definitionen von \ceil und \floor zu jedem Beitrag hinzugefügt. Daher wird jetzt auch alles in der Themenübersicht richtig angezeigt.]\(\endgroup\)


   Profil
matroid
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 12.03.2001
Mitteilungen: 14386
Wohnort: Solingen
  Beitrag No.9, eingetragen 2021-07-12

Hallo Nuramon, letzte Änderungen an der Reichweite von persönlichen Latex-Makros erfolgten im März: https://matheplanet.de/matheplanet/nuke/html/viewtopic.php?topic=252681&start=0&lps=1838228#v1838228 So könntet ihr recht haben, dass es einmal anders war. Und, ja, indem Wario seine Beiträge geändert hat, konnte ich das gemeldete Problem nicht mehr sehen. Da Wario erklärtermaßen kein Latex-Profil verwendet, kann es damit ja auch nicht zusammenhängen. Vielleicht beim nächsten Mal. Gruß Matroid


   Profil
Nuramon
Senior Letzter Besuch: in der letzten Woche
Dabei seit: 23.01.2008
Mitteilungen: 3018
  Beitrag No.10, vom Themenstarter, eingetragen 2021-07-12

\quoteon Vielleicht beim nächsten Mal. \quoteoff Der nächste "Wario macht etwas erstaunliches mit LaTeX"-Thread lässt sicher nicht allzu lange auf sich warten.


   Profil
Nuramon hat die Antworten auf ihre/seine Frage gesehen.
Nuramon hat selbst das Ok-Häkchen gesetzt.

Wechsel in ein anderes Forum:
 Suchen    
 
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © 2001-2021 by Matroids Matheplanet
This web site was originally made with PHP-Nuke, a former web portal system written in PHP that seems no longer to be maintained nor supported. PHP-Nuke is Free Software released under the GNU/GPL license.
Ich distanziere mich von rechtswidrigen oder anstößigen Inhalten, die sich trotz aufmerksamer Prüfung hinter hier verwendeten Links verbergen mögen.
Lesen Sie die Nutzungsbedingungen, die Distanzierung, die Datenschutzerklärung und das Impressum.
[Seitenanfang]