Matroids Matheplanet Forum Index
Moderiert von Stefan_K
Matroids Matheplanet Forum Index » Textsatz mit LaTeX » Layout des Abbildungsverzeichnisses ändern
Druckversion
Druckversion
Autor
Universität/Hochschule J Layout des Abbildungsverzeichnisses ändern
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Themenstart: 2007-10-14


Hallo zusammen,

da bin ich mal wieder.

Mein Abbildungsverzeichnis sieht im Moment so aus:

1.1 Abbildung 1
1.2 Abbildung 2

2.1 Abbildung 3
2.2 Abbildung 4

Da ich mit sehr vielen Grafiken arbeiten werde, möchte ich gerne zusätzlich die jeweilige Kapitelüberschrift und eine horizontale Linie einfügen:

Kapitelüberschrift 1
-----------------------------
1.1 Abbildung 1
1.2 Abbildung 2

Kapitelüberschrift 2
-----------------------------
2.1 Abbildung 3
2.2 Abbildung 4

Leider habe ich absolut keine Idee mehr, wie ich das erreichen könnte.
Ich habe mich mit dem tocloft-Packet versucht, aber nicht das richtige gefunden.


Vielen Dank im voraus
Kerrin



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.1, eingetragen 2007-10-14


Hallo Kerrin,

das kann man mit \addtocontents machen, beispielsweise
LaTeX
\addtocontents{lof}{Kapitelüberschrift 2\newline%
\rule[1ex]{\textwidth}{1pt}\newline}
oder ähnlich.

Viele Grüße,

StefanK




Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.2, vom Themenstarter, eingetragen 2007-10-14


Hallo Stefan,

erst einmal vielen dank. Die Möglichkeit hatte ich auch schon ins Auge gefasst. Ganz glücklich bin ich damit jedoch nicht, weil ich den Code in jedes Kapitel einfügen muss. Könnte man das auch "automatisieren"?


Kerrin



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Liam
Ehemals Aktiv Letzter Besuch: vor mehr als 3 Monaten
Dabei seit: 21.10.2006
Mitteilungen: 30
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.3, eingetragen 2007-10-14


Hi KerrinNicolaisen,
das Einfügen könntest du ja automatisieren. Speichere die alte chapter-Definition mittels \let\orgchapter=\chapter ab und definiere chapter unter Verwendung von orgchapter sowie den zusätzlichen Zeilen von Stefan neu.
Gruß Liam



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.4, vom Themenstarter, eingetragen 2007-10-14


Hallo Liam,

kannst Du mir erklären, wie ich dann orgchapter zu definieren hätte?
Ich kenne mich da leider noch nicht so aus.


Gruß Kerrin



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.5, eingetragen 2007-10-15


Hallo Kerrin,

mit LaTeX sollte sich viel automatisieren lassen.  wink

Mit beliebiger Dokumentklasse sollte es klappen, indem man sich in \chapter einklinkt.
LaTeX
\let\oldchapter=\chapter
\renewcommand{\chapter}[1]{\oldchapter{#1}%
  \addtocontents{lof}{\noindent\par%
  \underline{\thechapter~#1}\par}}

Damit wird am Beginn jedes Kapitels die Kapitelüberschrift in das Abbildungsverzeichnis geschrieben.
Wenn Du noch andere Makros verwendest, die selbst \chapter bzw. \chapter* aufrufen, wie \tableofcontents, sollte man obige Zeilen erst nach ihnen schreiben. Oder man definiert sich statt obigem ein \mychapter analog, das man aufruft statt \chapter, insbesondere wenn man auch Kapitel ohne Abbildungen hat. Übrigens habe ich oben \par eingefügt, um in lof vom vertikalen in den horizontalen Modus zu wechseln, und \noindent für gleichmäßige Einrückung.

StefanK




[Die Antwort wurde nach Beitrag No.2 begonnen.]



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Liam
Ehemals Aktiv Letzter Besuch: vor mehr als 3 Monaten
Dabei seit: 21.10.2006
Mitteilungen: 30
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.6, eingetragen 2007-10-15


Hi KerrinNicolaisen,
hier eine Lösung die auch am Anfang des Dokuments, also vor \tableofcontents u.a., stehen kann ohne Probleme zu verursachen.
LaTeX
\makeatletter
 
\newcommand{\old@chapter}{}
\let\old@chapter\chapter
 
\renewcommand{\chapter}{%
  \@ifstar{\new@chapterstar}{%
    \@ifnextchar[{\new@chapteropt}{\new@chapter}%
  }%
}
 
\newcommand{\new@chapterstar}[1]{%
  \old@chapter*{#1}%
}
 
\newcommand{\new@chapteropt}[2][]{%
  \old@chapter[#1]{#2}%
  \addtocontents{lof}{#1\protect\newline\protect\rule[1ex]{\textwidth}{1pt}\protect\newline}%
}
 
\newcommand{\new@chapter}[1]{%
  \old@chapter{#1}%
  \addtocontents{lof}{#1\protect\newline\protect\rule[1ex]{\textwidth}{1pt}\protect\newline}%
}
 
\makeatother 

Gruß Liam



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.7, eingetragen 2007-10-15


Hallo Liam,

die Lösung mit \@ifstar und \@ifnextchar gefällt mir, ich merk mir das, falls ich nochmal Makros mit Sternform und optionalem Parameter überschreiben möchte.

Die Zeile fürs lof könnte evtl. Probleme beim Übersetzen machen, mit dem \addvspace{10\p@}, was das originale \chapter ins lof schreibt, da kann ein voranstehendes \par wie oben helfen.

Viele Grüße,

StefanK




Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.8, vom Themenstarter, eingetragen 2007-10-15


Hallo,

das von Stefan beschriebene Problem ist bei dem Versuch die Lösung von Liam zu verwenden aufgetreten. Ich habe mich nun hauptsächlich an Stefans Lösung gehalten, aber auch Liams Variante hat mir entscheidende Denkanstöße gegeben. Das ist nun mein Code:
nameLatex
\documentclass[pdftex,10pt,twoside, fleqn]{scrbook}
 
\usepackage{tocloft}
\usepackage{calc}
 
\renewcommand{\cftfigpresnum}{Abb.~}
\setlength{\cftfignumwidth}{\widthof{Abb.~999 }}
 
\newcommand{\mychapter}[1]{\chapter{#1}}
 
\let\oldchapter=\mychapter
\renewcommand{\mychapter}[1]{\oldchapter{#1}%
    \addtocontents{lof}{
                          \protect\addvspace{6ex}
                          \protect\pagebreak[3]
                          \noindent
                          \protect\makebox[0pt][l]{\protect\rule[-3pt]{\textwidth}{0.5pt}}
                          {\large \textbf{\thechapter\hspace{1cm}#1}}\hfill\thepage
                          \par
                          \protect\nopagebreak
                          \protect
                        }}
 
\def\demofig{%
\begin{figure}
\centering\rule{2cm}{2cm}\caption{foo}
\end{figure}}
\begin{document}
 
\makeatletter
 
% Gliederungsnummer
\renewcommand{\numberline}[1]{\makebox[0.9cm][l]{#1}
                              \hspace{1mm}
                             }
 
% chapter
\renewcommand{\l@chapter}[2]{\addvspace{6ex}
                             \pagebreak[3]
                             \noindent
                             \makebox[0pt][l]{\rule[-3pt]{\textwidth}{0.5pt}}
                             {\large \textbf{#1}}
                             \hfill#2
                             \par
                             \nopagebreak
                             \addvspace{1ex}
                            }
 
\makeatother
 
\tableofcontents
 
\listoffigures
\clearpage
\mychapter{test}
\demofig
\demofig
\demofig
\end{document}

Leider steht im Abbildungsverzeichnis trotz der Änderung von \cftfigpresnum immer noch nur die Abbildungsnummer "1.1" statt "Abb. 1.1". Das Problem ist, dass ich für das Inhaltsverzeichnis \numberline umdefiniert habe. Wie kann ich die Definition wieder rückgängig machen?


Viele Grüße
Kerrin



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.9, vom Themenstarter, eingetragen 2007-10-15


Hallo,

ich habe jetzt vor den Änderungen für das Abbildungsverzeichnis noch
latex
\renewcommand{\numberline}[1]{\makebox[2cm][l]{\cftfigpresnum #1:}
                              \hspace{1mm}
                             }

eingefügt. Voerst und hoffentlich auch endgültigt hat sich dieses Problem damit erledigt.


Vielen Dank für Eure Hilfe
Kerrin
[ Nachricht wurde editiert von KerrinNicolaisen am 15.10.2007 11:44:57 ]



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.10, vom Themenstarter, eingetragen 2007-11-13


Hallo,

meine Abbildungen haben sehr lange Titel. Zur Zeit arbeite ich mit
latex
\renewcommand{\numberline}[1]{\makebox[2cm][l]{\cftfigpresnum #1:}
                              \hspace{1mm}}

Nach dem Doppelpunkt habe ich einen Abstand, wolh auch sinnvoll. Für kurze Titel sieht das Verzeichnis so auch schön aus, nur habe ich auch Titel, die sich über zwei Zeilen erstrecken. Statt

ein ganz ganz ganz
langer Titel

sieht das ganze so aus:

   ein ganz ganz ganz  
langer Titel

Der Grund ist offenbar der eingefügte Abstand. Ich habe überlegt, eine in iregendeiner Form eine Box einzufügen, nur leider klappt das bei mir nicht. Gibt es eine Möglichkeit den Text linksbündig oder im Flattersatz (so werden hoffentlich die enormen Abstände zwischen den Wörtern vermieden) darzustellen?


Vielen Dank
Kerrin




Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.11, eingetragen 2007-11-13


Hallo Kerrin,

ist das eine Absatzeinrückung? Ein vorangestelltes \noindent mag helfen.
Ansonsten zeig vielleicht mal ein Minimalbeispiel, woran man das Problem sieht und beheben kann.

Viele Grüße,

StefanK




Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.12, eingetragen 2007-11-13


Hi Kerrin,

vergiss das mit dem Minimalbeispiel, ich sehe den Bezug zu den anderen Posts samt Quellcode.
Mal schaun!

StefanK



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.13, vom Themenstarter, eingetragen 2007-11-13


Hallo Stefan,

entschuldige, das Minimalbeispiel hatte ich vergessen. Falls es Dir doch noch hilft:
latex
\documentclass[pdftex,10pt,twoside, fleqn]{scrbook}
 
\usepackage{tocloft}
\usepackage{calc}
 
\renewcommand{\cftfigpresnum}{Abb.~}
\setlength{\cftfignumwidth}{\widthof{Abb.~999 }}
 
\newcommand{\mychapter}[1]{\chapter{#1}}
 
\let\oldchapter=\mychapter
\renewcommand{\mychapter}[1]{\oldchapter{#1}%
    \addtocontents{lof}{
                          \protect\addvspace{6ex}
                          \protect\pagebreak[3]
                          \noindent
                          \protect\makebox[0pt][l]{\protect\rule[-3pt]{\textwidth}{0.5pt}}
                          {\large \textbf{\thechapter\hspace{1cm}#1}}\hfill\thepage
                          \par
                          \protect\nopagebreak
                          \protect
                        }}
 
\begin{document}
 
\makeatletter
 
% Gliederungsnummer
\renewcommand{\numberline}[1]{\makebox[2cm][l]{\cftfigpresnum #1: \hspace{1mm}}}
 
\renewcommand{\cftfigpresnum}{Abb.~}
 
\setlength{\cftfignumwidth}{\widthof{Abb.~999}}
 
% Einzug der Abbildungsnummer
\setlength\cftfigindent{1cm}
 
% keine Punkte
\renewcommand{\cftdot}{}
 
\setlength\cftparskip{1ex}
 
% chapter
\renewcommand{\l@chapter}[2]{\addvspace{6ex}
                             \pagebreak[3]
                             \noindent
                             \makebox[0pt][l]{\rule[-3pt]{\textwidth}{0.5pt}}
                             {\large \textbf{#1}}
                             \hfill#2
                             \par
                             \nopagebreak
                             \addvspace{1ex}
                            }
 
\makeatother
 
\listoffigures
\clearpage
\mychapter{test}
\begin{figure}
\centering\rule{2cm}{2cm}\caption{ein ganz ganz ganz ganz ganz ganz ganz ganz ganz ganz langer Titel}
\end{figure}
\end{document}

ein und langer soll(t)en untereinander stehen.

Kerrin

[ Nachricht wurde editiert von KerrinNicolaisen am 13.11.2007 02:36:12 ]



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.14, eingetragen 2007-11-13


Hallo Kerrin,

wäre es vielleicht gut für Dein Dokument, als Bildunterschrift die lange caption zu setzen und für das Verzeichnis eine kürzere anzugeben? Das macht man mit
LaTeX
\caption[kürzerer Titel]{ganz langer Titel}
Dann wird das Basteln für Bündigkeit unnötig - für die Liste der Abbildungen mag ja ein Kurztitel genügen.

Viele Grüße,

StefanK



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.15, vom Themenstarter, eingetragen 2007-11-13


Hallo Stefan,

mein Dokument hat nicht das übliche DIN A4-Format, sondern ist nur 16.5cm breit. \textwidth habe ich daher mit 12cm belegt. Kurztitel verwende ich schon, nur habe ich den Bereich für den Titel durch die verwendeten Abstände so eingeschränkt, dass der Titel dennoch zu lang ist. Hättest du eine Idee, wie ich ansetzten müßte, um die Bündigkeit zu erhalten?


Kerrin



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.16, eingetragen 2007-11-13


Hallo Kerrin,

zunächst würde ich ein Boxmakro mit top-Ausrichtung definieren:
LaTeX
\newcommand\topbox[2]{\parbox[t]{#1}{\raggedright #2}}

Der Grund für ein eigenes Makro, statt direkt \parbox[t]{...}{...} in der caption zu schreiben, ist die Zerbrechlichkeit - man braucht ein \protect, und der Parameter [t] kann Probleme machen - so ist es jedenfalls sauberer und funktioniert.

Im Text dann:
\caption[\protect\topbox{LAENGE}{langer Titel}]{ganz langer Titel}

Viele Grüße,

StefanK



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.17, vom Themenstarter, eingetragen 2007-11-13


Hallo Stefan,

vielen Dank. Genau das habe ich gesucht.


Kerrin



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.18, vom Themenstarter, eingetragen 2007-12-03


Hallo,

beim Durchsehen meiner Arbeit ist mir aufgefallen, dass die Überschrift des Abbildungsverzeichnisses wie üblich schwarz, fett und linksbündig ist. In meinem Dokument habe ich den Überschriften ein neues Aussehen verpasst, das natürlich auch für das Abbildungsverzeichnis gelten soll.

Soweit ist dies auch kein Problem ich habe dazu
latex
\makeatletter
\renewcommand*\listoffigures{\chapter*{Abbildungsverzeichnis}%
                               \@starttoc{lof}
                              }
\makeatother
eingefügt. Leider werden nun aber die Abstände zwischen den einzelnen Abbildungen schlichtweg ignoriert. Diese habe ich, zumindest zuvor, mit
latex
\setlength\cftparskip{1ex}
erzeugt.

Hier ist mein komplettes Minimalbeispiel:
latex
\documentclass[pdftex,10pt,twoside, fleqn]{scrbook}
\usepackage{titlesec}
\usepackage{tocloft}
\usepackage{calc}
\usepackage{color}
 
% Formatierung der Kapitelüberschrift
\definecolor{grau}{rgb}{0.5, 0.5, 0.5}
\titleformat{\chapter}[block]
    {\filleft\normalfont\sffamily}{}{0pt}{\chapterformat}
    \titlespacing*{\chapter}{0pt}{*3}{*10}[1pc]
\renewcommand{\chapterformat}[1]{%
    \parbox[b]{.5\textwidth}{\filleft\fontsize{18}{18}\bfseries \textcolor{grau}{#1}}%
    \color{white}{\rule[-12pt]{1pt}{65pt}}}
 
\newcommand{\mychapter}[1]{\chapter{#1}}
 
\def\demofig{%
\begin{figure}
\centering\rule{2cm}{2cm}\caption{foo}
\end{figure}}
\begin{document}
 
% Formatierung des Abbildungsverzeichnisses
\makeatletter
\renewcommand*\listoffigures{\chapter*{Abbildungsverzeichnis}%
                               \@starttoc{lof}
                              }
\makeatother
 
\let\oldchapter=\mychapter
\renewcommand{\mychapter}[1]{\oldchapter{#1}%
    \addtocontents{lof}{
                          \protect\addvspace{6ex}
                          \protect\pagebreak[3]
                          \noindent
                          \protect\makebox[0pt][l]{\protect\rule[-3pt]{\textwidth}{0.5pt}}
                          {\large \textbf{\thechapter\hspace{1cm}#1}}\hfill\thepage
                          \par
                          \protect\nopagebreak
                          \protect
                        }}
 
\renewcommand{\numberline}[1]{\makebox[2cm][l]{\cftfigpresnum #1:}}
\renewcommand{\cftfigpresnum}{Abb.~}
\setlength{\cftfignumwidth}{\widthof{Abb.~999}}
 
% Einzug der Abbildungsnummer
\setlength\cftfigindent{1cm}
 
% keine Punkte
\renewcommand{\cftdot}{}
 
% Abstand zwischen den Einträgen
\setlength\cftparskip{1ex}
 
\listoffigures
 
 
\clearpage
\mychapter{test}
\demofig
\demofig
\demofig
\end{document}

Egal wie groß ich den Abstand wähle, es passiert nichts. Kommentiere ich aber die Änderung für \listoffigures aus, wird auch der Abstand entsprechend angepasst.

Hat jemand einen Lösungsansatz für mich?
Ich bin für jede Idee dankbar.

Kerrin
 



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.19, eingetragen 2007-12-03


Hallo Kerrin,

Deine Anpassung für das Abbildungsverzeichnis scheint zu KOMA-Script zu passen, aber nicht zu tocloft. tocloft erstellt das Abbildungsverzeichnis anders. Daher würde ich als nicht \listoffigures redefinieren sondern \@cftmakeloftitle, was bei tocloft die Überschrift ausgibt:
LaTeX
\renewcommand*\@cftmakeloftitle{%
  \addpenalty\@secpenalty
  \if@cfthaschapter
    \vspace*{\cftbeforeloftitleskip}
  \else
    \vspace{\cftbeforeloftitleskip}
  \fi
  \@cftpagestyle
  {\interlinepenalty\@M
  {\chapter*{Abbildungsverzeichnis}}{\cftafterloftitle}
  \cftmarklof
  \par\nobreak
  \vskip \cftafterloftitleskip
  \@afterheading}}

Hierbei habe ich \cftloftitlefont\listfigurename durch den \chapter*-Aufruf ersetzt, um die Kapiteltitel-Formatierung zu übernehmen.

Viele Grüße,

StefanK




Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.20, vom Themenstarter, eingetragen 2007-12-03


Hallo Stefan,

genau das habe ich gesucht. Da ich selbiges Problem mit dem Inhalteverzeichnis hatte, habe ich nach dem ersetzen von lof durch toc den Code auch dort eingesetzt.

Mein Inhaltsverzeichnis geht über mehrere Seiten. Jede Seite, außer bei Kapitelanfängen und leeren Seiten enthält eine Kopfzeile. Leider fehlt diese auf der zweiten Seite des Inhaltsverzeichnisses jetzt (siehe Beispiel).
latex
\documentclass[pdftex,10pt,twoside, fleqn]{scrbook}
\usepackage{titlesec}
\usepackage{tocloft}
\usepackage{color}
\usepackage{fancyhdr}
 
% Seitenparameter bestimmen
\pagestyle{fancy}
 
% Kopfzeile
\fancyheadoffset[RO,LE]{2.3cm}
\fancyhf{}
\fancyhead[LE]{\qquad\qquad Buchtitel}
\renewcommand{\chaptermark}[1]{\markboth{#1}{}}
\fancyhead[RO]{\leftmark \qquad\qquad}
 
% Fußzeile
\fancyfoot[RO,LE]{\thepage}
 
% Formatierung der Kapitelüberschrift
\definecolor{grau}{rgb}{0.5, 0.5, 0.5}
\titleformat{\chapter}[block]
    {\filleft\normalfont\sffamily}{}{0pt}{\chapterformat}
    \titlespacing*{\chapter}{0pt}{*3}{*10}[1pc]
\renewcommand{\chapterformat}[1]{%
    \parbox[b]{.5\textwidth}{\filleft\fontsize{18}{18}\bfseries \textcolor{grau}{#1}}%
    \color{white}{\rule[-12pt]{1pt}{65pt}}}
 
\begin{document}
 
\makeatletter
 
% Inhaltsverzeichnis
\renewcommand*\@cftmaketoctitle{%
  \addpenalty\@secpenalty
  \if@cfthaschapter
    \vspace*{\cftbeforetoctitleskip}
  \else
    \vspace{\cftbeforetoctitleskip}
  \fi
  \@cftpagestyle
  {\interlinepenalty\@M
  {\chapter*{Inhaltsverzeichnis}}{\cftaftertoctitle}
  \cftmarktoc
  \par\nobreak
  \vskip \cftaftertoctitleskip
  \@afterheading}}
 
% Gliederungsnummer
\renewcommand{\numberline}[1]{\makebox[0.9cm][l]{#1}
                              \hspace{1mm}
                             }
 
% chapter
\renewcommand{\l@chapter}[2]{\addvspace{10ex}
                             \pagebreak[3]
                             \noindent
                             \makebox[0pt][l]{\rule[-3pt]{\textwidth}{0.5pt}}
                             {\large \textbf{#1}}
                             \hfill#2
                             \par
                             \nopagebreak
                             \addvspace{1ex}
                            }
% section
\renewcommand{\l@section}[2]{\addvspace{1ex}
                                \noindent
                                \hspace{1cm}
                                #1\hfill#2
                                \par
                                \nopagebreak[2]
                               }
 
% subsection
\renewcommand{\l@subsection}[2]{\noindent
                                \hspace{1.6cm}
                                #1\hfill#2
                                \par
                                \nopagebreak[2]
                               }
 
% Abbildungsverzeichnis
\makeatletter
\renewcommand*\@cftmakeloftitle{%
  \addpenalty\@secpenalty
  \if@cfthaschapter
    \vspace*{\cftbeforeloftitleskip}
  \else
    \vspace{\cftbeforeloftitleskip}
  \fi
  \@cftpagestyle
  {\interlinepenalty\@M
  {\chapter*{Abbildungsverzeichnis}}{\cftafterloftitle}
  \cftmarklof
  \par\nobreak
  \vskip \cftafterloftitleskip
  \@afterheading}}
\makeatother
 
 
\makeatother
 
\tableofcontents
 
\listoffigures
 
 
\clearpage
\chapter{test}
\chapter{test}
\chapter{test}
\chapter{test}
\chapter{test}
\chapter{test}
\chapter{test}
\chapter{test}
 
\end{document} 

Im Beispiel sind auch auf leeren Seiten Kopfzeilen. Ich habe dies nicht geändert, weil das bei mir richtig läuft.


Gruß
Kerrin



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Stefan_K
Senior Letzter Besuch: im letzten Quartal
Dabei seit: 13.07.2005
Mitteilungen: 4353
Aus: Hamburg
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.21, eingetragen 2007-12-03


Hallo Kerrin,

da funkt der Seitenstil von tocloft dazwischen. Das kannst Du verhindern:
LaTeX
\renewcommand*\@cftpagestyle{}

Nun sollte sich der Stil wieder nach fancy richten, so dass die 2. Seite des Inhaltsverzeichnisses wieder eine Kopfzeile erhält.

Mit scrbook würde ich übrigens scrpage2 statt fancyhdr benutzen.

Viele Grüße,

StefanK



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied
Zum letzten BeitragZum nächsten BeitragZum vorigen BeitragZum erstem Beitrag  Beitrag No.22, vom Themenstarter, eingetragen 2007-12-03


Hallo Stefan,

vielen Dank für den Tipp. Auch das Problem ist behoben.


Gruß,
Kerrin



Eine Notiz zu diese Forumbeitrag schreiben Notiz   Profil  Quote  Link auf diesen Beitrag Link
Ehemaliges_Mitglied hat die Antworten auf ihre/seine Frage gesehen.
Ehemaliges_Mitglied hat selbst das Ok-Häkchen gesetzt.
Neues Thema [Neues Thema]  Druckversion [Druckversion]

 


Wechsel in ein anderes Forum:
 Suchen    
 
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © 2001-2020 by Matroids Matheplanet
This web site was originally made with PHP-Nuke, a former web portal system written in PHP that seems no longer to be maintained nor supported. PHP-Nuke is Free Software released under the GNU/GPL license.
Ich distanziere mich von rechtswidrigen oder anstößigen Inhalten, die sich trotz aufmerksamer Prüfung hinter hier verwendeten Links verbergen mögen.
Lesen Sie die Nutzungsbedingungen, die Distanzierung, die Datenschutzerklärung und das Impressum.
[Seitenanfang]